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Overview

MAPI Message Pad is a telephone message system that supplements or replaces the traditional
"While You Were Out" message pad.  

Message Pad utilizes the messaging services (MAPI) provided by Windows for Workgroups TM

and Microsoft Mail 3.0TM.  It requires a post office and user accounts created with either Microsoft
Mail 3.x or the Mail application provided with Windows for Workgroups.  Because of its ability to
access the accounts on your existing Mail system, Message Pad is very easy to install, use and
maintain.  

Message Pad is tightly integrated with MS Mail.  Messages sent with Message Pad appear in
the MS Mail Inbox and can be viewed in either MS Mail or Message Pad.  One advantage of this
close integration is that you do not need to run Message Pad all of the time in order to be
notified of new Message Pad messages.  If MS Mail is running, it will trigger a dialog box which
will notify you that you have received a new phone message. 

Order information can be found at the end of this manual, and an order form (ORDER.WRI) is
also included.  

New Features in Message Pad 3.0

* Caller Search, which uses a database of previous callers to automatically fill in the
caller's name, company and phone number.  Caller Search looks up matches as you
type the caller's name.

* Recipient Lookup and PickList

* Phone Messages in MS Mail Folders Can Be Viewed in Message Pad

* Outgoing and Incoming Messages are Logged to Comma-Delimited Text Files

* Improved Message Forwarding

* Improved Message Management with Follow-Up Checkboxes

* Message Pad's icon changes to reflect unread messages

Installation

System Requirements

Message Pad requires a post office and user accounts created with MS Mail 3.x or
the  Mail  application  provided  with  Windows  for  Workgroups.   When  you  start
Message Pad, it will automatically log on to your regular MS Mail account.



To install Message Pad using the Setup program

* Insert the Setup disk in drive a or drive b.

* From Program Manager's File menu, choose Run.

* In the Command Line box, type a:\setup or b:\setup

Starting Message Pad

You can start Message Pad from its Program Manager icon or from Microsoft Mail.  There are
two ways to start Message Pad from Microsoft Mail:

* Select  "Message Pad"  from the Mail  menu in  MS Mail.   This  will  start  Message Pad or
activate the current session if it is already running.  This menu item is added to MS Mail by
Message Pad's Setup program.  If MS Mail was running when Message Pad was installed,
you need to quit MS Mail and restart it in order for this change to take effect.

* Open a Message Pad message from MS Mail's InBox or any other Mail folder.  Message Pad
messages can be identified in Mail folders by the word "PHONE:" at the beginning of the
subject line.  By default, Message Pad messages that are opened from Mail will be displayed
in Message Pad.  This can be changed by selecting "Preferences" from the Options menu,
and unchecking the check box labeled: "Launch Message Pad when message opened in
Mail."

Sending Messages from Message Pad

To send a message

* Click the "Compose" button or choose "Compose Message" from the File menu.  This clears
Message Pad and enters the current date and time.   You can also create a new message by
clicking the rolodex button next to the "To" box.  This will let you select the recipient from your
address book.

* Enter the name of the recipient of the message in the "To" box . 

* Enter the name and phone number of the caller and other pertinent information .  Press TAB to
move the insertion point to the next box.  Press SHIFT-TAB to move to the previous text box.

* Click the "Send" button, choose "Send Message" from the File menu, or press CTL-S.

Recipient Pick List

Message Pad lets you create a pick list of people who are frequent message recipients.  Names
can be selected from the pick list by clicking the down arrow button next to the "To" box or by
pressing the Down Arrow key on your keyboard when the cursor is in the "To" box.  

The pick list is also used to autofill the "To" box.  As you type the recipient's name, Message Pad
will check for matching names in the pick list and will automatically fill in the rest of the name for
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you.  

To modify the the pick list, select "Recipient Pick List" from the "Options" menu.  This will display
the "Recipient List" dialog box, which allows you to add or remove names from the recipient pick
list.  You can add names directly from your Mail Address Book by clicking the Address Book
button in the "Recipient List" dialog.

The recipient pick list is maintained in a text file named RECIPS.LST in your Message Pad
directory.

Verifying Recipient Mail Addresses

When you send a message, Message Pad automatically verifies the recipient's name.  If the
name does not match a valid user account, the message will not be sent.  If you entered a
partial name, for instance the first name only, Message Pad will attempt to match that name with
an  existing  account.   If  the  partial  name  matches  more  than  one  user  account,  you  are
presented with a list of matching names to choose from.

If you are unsure of the correct  name you can type the first few characters of the user's name
and click the checkmark button next to the "To" box.  Message Pad fills in the rest of the name if
it is valid.  If there is more than one matching name, you can select from among the matches.

Caller Search

Caller Search uses a database of previous callers to help you fill in the name, company and
phone number of callers.  Caller Search is activated when you click the Compose button (or
select New Message from the File menu), and it searches for matches as you type in the caller's
name.  When the message is sent, Caller Search automatically updates its database.  Multiple
users can share the same Caller Search database.

Caller Search can be enabled or disabled by selecting "Caller Search..." from the Options menu.

Caller Search uses the Access 1.1 data engine.  The MSGPAD.MDB file (which contains a table
named CALLERS) can be read by Access 1.1. 

Working With Messages You've Received

Message Pad checks your Mail account for new phone messages at the time interval specified
in the Preferences dialog.  You can also direct Message Pad to check for new messages by
clicking the "Get New" button or selecting "Get New Messages" from the File menu.

When new messages are received, they are listed in the Pending Messages listbox.  Unread
messages  have  a  pink  message  slip  icon.   Messages  that  have  been  read  have  a  white
message slip icon.  Urgent messages are also preceded by an exclamation mark icon.

You can perform the following actions on received messages:

* Display the message - Select the message in the Pending Messages listbox

* Print  the  message -  Display  the  message  and  click  the  "Print"  button  or  choose  "Print
Message" from the File menu.  
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* Forward the  message to  another  person -  Display the  message and  click  the  "Forward"
button.  Then enter the mailbox name of the person to receive the message in the displayed
dialog box.  Message Pad adds the text "Message Forwarded by [Your Name]" to the Note
text box and sends the message.  It adds the text "Message Forwarded to [new recipient's
name]" to your copy of the message.

* Delete the message from the Pending Messages listbox - Select the message in the "Pending
Messages" listbox and click the "Delete" button or choose "Delete Message" from the File
menu.  Deleting a message also clears the message pad.

* Save  changes  to  the  message -  Display  the  message  and  make  the  desired  changes.
Choose "Save Message" from the File menu or click the "Save" button.

* Record Followup Activities  - Diplay the message and select the appropriate check marks
under  the  "Follow-Up"  heading,  e.g.  Returned Call,  Left  Message,  etc.   The message is
automatically saved whenever a Follow-Up checkmark is selected or unselected. 

Notification of New Messages

Message Pad checks your Mail account for new phone messages at the time interval specified
in the Preferences dialog.  If  a new message is received while Message Pad is minimized, a
dialog box pops up over your current application to notify you that you have received a new
message. 

If MS Mail is running, but Message Pad is not, you will be notified by a popup dialog box when
new Message Pad messages are received by MS Mail. 

If there are any unread phone messages in your Inbox, Message Pad's icon will display an arm
holding a telephone.  If there are no unread phone messages, Message Pad's icon will display a
telephone with a message pad next to it.

Message Logging

Message Pad automatically logs all incoming and outgoing messages to comma delimited text
files.  By default, outgoing messages are logged to "MSGPAD.LOG" and messages you receive
are logged to "RCVD.LOG"; both files are initially placed in the Message Pad directory.  You can
disable message logging or change the name and directory of the message log files by selecting
"Message Logs..." from the Options menu.  

Messages that you receive are logged when the message is deleted so that any changes you
make to the message and any recorded follow-up activities are included in the log.  Note that the
message must be deleted from Message Pad and not from MS Mail in order for the message to
be added to the log file.

Messages are saved in comma delimited text files because this is a widely recognized format
that is supported by most word processors, spreadsheet programs and database programs.  

Phone Dialer

If you have a modem with a phone connected to it, Message Pad can automatically dial the
caller's number for you.  To dial a phone number, click the button with the telephone icon or
select "Dialer" from the Options menu.  You can set the Com port and modem dial strings by
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selecting "Setup" from the Dialer dialog box.

Setting Message Pad Preferences

New Message preferences and the default Action settings can be changed in the Preferences
dialog  box.   The  Preferences  dialog  box  is  displayed  by  selecting  "Preferences"  from  the
Options menu.

Default Action settings

The default action settings are the Action checkboxes (i.e., Returned your call, Please Call, etc.)
that are automatically checked when you select Compose from the toolbar or the File menu.
The default Action settings can be changed in the Preferences dialog by selecting new actions
and clicking OK.

New Message settings

* In the "Check for new messages" box, type how often you want Message Pad to look for new
phone messages.

* If you want Message Pad to notify you audibly when you receive a new phone message,
select the "Sound chime" check box.

Other preferences

* "Launch Message Pad when message opened in Mail" - Message Pad phone messages are
listed in Microsoft Mail's Inbox.  If you want phone messages to be displayed by Message
Pad when they are opened in MS Mail,  select this checkbox.  If this box is not checked,
phone messages will be displayed in Mail like any other message.

IMPORTANT If Microsoft Mail is running, changes to the "Launch Message Pad" 
setting do not take effect until you Exit and Restart MS Mail.

* "Clear Message Pad when Address Book is used" - If this box is checked, the message pad is
cleared and the time and date are reset when a name is selected from the Address Book.

MAPI Session / Re-Login to Mail Server

Message Pad uses MAPI message services.   If  another  MAPI  application,  e.g.  MS Mail  or
Schedule+,  is already running when Message Pad is started, it will log in to the existing MAPI
session.  If another MAPI session is not already running, Message Pad will begin a new one and
will require you to log-in with your user account name and password.

In previous versions of Message Pad, a Mailbox icon with the title "MS Mail Spooler (auto)"
appeared at the bottom of your screen if Message Pad started a new MAPI session.  This is no
longer  true  for  Message Pad 3.0.   Now,  the  icon displays  momentarily  when a new MAPI
session is initiated, and then the icon disappears.

If for some reason the MAPI session becomes disconnected, you can Re-Login by selecting
"Re-Login to Mail Server" from the Options menu.  If you are still unable to reconnect to the
network post-office, close all MAPI applications and re-start them.
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Technical Support

Technical support is provided via CompuServe or Internet E-Mail.  Questions should be sent to
CompuServe ID 73617,323 or via the Internet to bstine@efn.org.

German Language Version

We are working on a German language version of Message Pad 3.0.  If you are interested in
obtaining  more  information  about  this  version,  please  send  a  message  to  Brian  Stine  at
CompuServe ID 73617,323 or via the Internet to bstine@efn.org.

Ordering Message Pad 

Orders for Message Pad can be placed by completing the Order form (ORDER.WRI in your
MSGPAD directory) and mailing it with payment or purchase order to: 

Sahalie Software
3320 Harris Street

Eugene, OR  97405

License fees for Message Pad are based on the number of users, as follow:

2 users $30
5 users $60
10 users $100 

For more than 10 users, the license fee is $45 per every 5 users.  For licenses exceeding 25
users, please E-Mail a request for a corporate fee schedule to CompuServe ID 73617,323 or
mail your request to Sahalie Software at the above address.

5 User and 10 User Licenses for Message Pad can also be ordered through CompuServe's
Software Registration Database (GO SWREG).    5 User License - ID 1541, 10 User License -
ID 1544.

© 1992-1995  Brian D. Stine.  All rights reserved.
Microsoft Windows and Microsoft Mail are trademarks of Microsoft Corp.
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